#DeepinDE #Arch ¿Cómo instalar el escritorio Deepin en Arch linux y derivados (#EndeavourOS #XFCE)? - Legión GA

Página oficial de Legión GNU/Linux de la comunidad de Telegram

Únete a Telegram

26 jul 2021

#DeepinDE #Arch ¿Cómo instalar el escritorio Deepin en Arch linux y derivados (#EndeavourOS #XFCE)?

 


Hola bienvenidos de nuevo a mi blog aclaro que esto puede que tengas algún tipo de bug por lo que aconsejo que primero pruebes en una maquina que no uses para el uso diario. Les aclararé el tipo de error que tengo al final del post. 

Para instalar el escritorio o entorno debemos primero actualizar todas las bases de datos , luego instalar los paquetes "deepin" , deepin-extra . Si estas en endeavour como es mi caso necesitas desinstalar un paquete que depende la terminal xfce "endeavouros-xfce4-terminal-colors". Entonces haremos los siguiente : 

$ sudo pacman -Syuu 

$ sudo pacman -S deepin deepin-extra 

Usando pacman no se instalará lo más reciente del escritorio , lógicamente lo mas nuevo está de AUR ,esto hará que algunas cosas no aparezcan como la versión deepin V20.2 ya que se quitó la parte de gestionar en la terminal el blur , en la parte de personalización el efecto lampara por que no aparece. 

Una vez instalado reinicia la computadora y entra en tu usuario. Por último sigue los pasos que aparecen a continuación:

# Eliminar las configuraciones de colores personalizadas de endeavourOS en la terminal 

$  sudo pacman -Rs   endeavouros-xfce4-terminal-colors 

Esto lo ejecuté así para que no deje residuos. 

 Ahora en mi caso borro a XFCE totalmente porque en realidad no me gusta y tenia ganas de cambiar. 

 $ sudo pacman -Rs xfce4 xfce4-goodies


Acá la lista de paquetes que elimina : 
Paquetes (43) colord-1.4.5-4  libgusb-0.3.7-1  libkeybinder3-0.3.2-3  libxfce4ui-4.16.0-1  libxfce4util-4.16.0-1  libxpresent-1.0.0-2  polkit-gnome-0.105-8
              vte-common-0.64.2-2  vte3-0.64.2-2  xorg-iceauth-1.0.8-2  exo-4.16.2-1  garcon-4.16.1-1  parole-4.16.0-1  ristretto-0.11.0-1  thunar-4.16.8-1
              thunar-archive-plugin-0.4.0-3  thunar-media-tags-plugin-0.3.0-2  thunar-volman-4.16.0-1  tumbler-4.16.0-3  xfce4-appfinder-4.16.1-2
              xfce4-battery-plugin-1.1.4-1  xfce4-cpufreq-plugin-1.2.5-1  xfce4-datetime-plugin-0.8.1-1  xfce4-mount-plugin-1.1.5-1  xfce4-netload-plugin-1.4.0-1
              xfce4-notifyd-0.6.2-2  xfce4-panel-4.16.3-2  xfce4-power-manager-4.16.0-3  xfce4-pulseaudio-plugin-0.4.3-1  xfce4-screensaver-4.16.0-1
              xfce4-screenshooter-1.9.9-2  xfce4-session-4.16.0-2  xfce4-settings-4.16.2-1  xfce4-taskmanager-1.4.2-1  xfce4-terminal-0.8.10-2
              xfce4-wavelan-plugin-0.6.2-1  xfce4-weather-plugin-0.11.0-1  xfce4-whiskermenu-plugin-2.5.3-1  xfce4-xkb-plugin-0.8.2-1  xfconf-4.16.0-2
              xfdesktop-4.16.0-2  xfwm4-4.16.1-2  xfwm4-themes-4.10.0-4


Suele pasar que te deja el indicador de red de gnome en gtk2 en la parte inferior por lo que se puede borrar tranquilamente , el paquete creo que se llama "network-manager". No borres el que diga QT5 es el propio de deepin. Si tienen "añadir y quitar software" te dará más facilidad a la hora de buscar y ver que hace cada cosa. 

Borrar las carpetas de configuración que no se necesita , por lo general se llama xfce4 dentro de .local .config los gtk2 gtk3 sugiero que veas primero que eliminar del todo. Por si no estas seguro solo mándalo a la papelera y ya luego agarras y lo restauras si causa algún problema.  


Los posibles bugs , bueno en mi caso cuando quiero cambiar el fondo de escritorio no me deja , creo que está mal configurado el kwin también(creo que sirve de algo presionar las teclas alt+control+tab se recupera el escritorio al menos en mi caso). Estuve viendo el tema que cuando tenia el escritorio instalado de xfce me salia doble barra en las ventanas  por lo que tuve que instalar el paquete desde plasma con "sudo pacman -S  systemsettings" es el centro de control de plasma y luego me fui a la parte de la ventanas, elegí la opción de no mostrar bordes y listo. Con esto fue todo. Espero verlos en mi Grupo de telegram "Legión GNU/Linux" el enlace está en la parte superior.  





No hay comentarios.:

Publicar un comentario